SET 39 Call For Papers

¿Eres un hacker? Si deseas pasar a formar parte de la historia del hacking hispano, colabora con la próxima edición de SET 39 enviándonos un artículo. No esperes más, esta es tu oportunidad de demostrar lo que sabes. Ayúdanos a construir una revista de hackers para hackers. SET Staff

Routers Cisco I

      3341

Autor: Hendrix
-[ 0x08 ]--------------------------------------------------------------------
-[ ROUTERS CISCO I ]---------------------------------------------------------
-[ by Hendrix ]-------------------------------------------------------SET-18-

CURSO DE ROUTERS CISCO (I)
**************************
por  Hendrix, <jm_hendrix@axis.org>  

Este es el primer articulo que escribo para SET, si no os gusta lo siento
por vosotros porque pienso escribir muchos mas...

Introduccion:

Los Routers son los aparatos encargados de encaminar los paquetes que 
circulan por una red, en definitiva son ellos los que forman el nucleo de 
Internet. Un Router recoge el paquete que le llega, lo analiza y decide cual
es camino que debe seguir para llegar a su destino, haciendo de puente entre 
los distintos medios de transmision (Frame Relay, X.25, RDSI, etc..) y los
distintos protocolos. Fisicamente un Router no es mas que un ordenador
dedicado, es decir tiene su Microprocesador, su memoria y hasta su Sistema
Operativo!

La empresa CISCO acapara el 70% del mercado de los routers, es algo asi como
Microsoft en el software. Para comprender el funcionamiento practico de
estos aparatos lo mejor es conocer el Sistema Operativo de Cisco: CISCO IOS.

[IOS stands for Internetworking Operating System, capici?]

Modelos:

El modelo mas sencillo de CISCO es el 761, un peque~o router RDSI pensado
para peque~as oficinas. Este router no tiene sistema operativo y se
configura localmente conectandose al puerto serie. Tambien puede configurarse
via telnet. La serie 1000 de Cisco ya incorpora el CISCO IOS y sobre este
tipo de aparatos nos centraremos en el curso. Los otros modelos: series 2000,
2600, 3000, 4000, etc. funcionan basicamente igual, eso si, contra mas 
grande sea el modelo mas cosas tiene, mola mas y vale mas pelas.

Otro dia podria dedicarle mas tiempo a explicar como es cada modelo (si a
alguien le interesa que me lo diga o que mire el la web de Cisco).


Vamos pa'dentro:

Lo mejor que podemos hacer es entrar en un Router y asi queda todo mucho mas
claro que si suelto una parrafada teorica de las mias.
Vamos p'alla, suponemos que hacemos un telnet a la direccion x.x.x.x donde
esta el router. Esto es lo que pasara:

> telnet x.x.x.x

User Access Verification

Password: ********

router>

$$$ Entramos la contrase~a y ya estamos dentro (en principio no pide login)
$$$ Ahora nos aparece el interprete de comandos. El comando mas sencillo es 
$$$ el Help, "?" que nos da una lista de los comandos posibles

router> ?
<1-99>           Session number to resume
  connect          Open a terminal connection
  disable          Turn off privileged commands
  disconnect       Disconnect an existing network connection
  enable           Turn on privileged commands
  exit             Exit from the EXEC
  help             Description of the interactive help system
  lock             Lock the terminal
  login            Log in as a particular user
  logout           Exit from the EXEC
  name-connection  Name an existing network connection
  pad              Open a X.29 PAD connection
  ping             Send echo messages
  ppp              Start IETF Point-to-Point Protocol (PPP)
  resume           Resume an active network connection
  show             Show running system information
  slip             Start Serial-line IP (SLIP)
  systat           Display information about terminal lines
  telnet           Open a telnet connection
  terminal         Set terminal line parameters
  traceroute       Trace route to destination  
  tunnel           Open a tunnel connection
  where            List active connections
  x3               Set X.3 parameters on PAD       

$$$ Estos no son todos los comandos que tiene ya que como veis no hay ninguno
$$$ de configuracion, para ver mas cosa hay que entrar en modo enable con la
$$$ orden "enable" (evidente, no?)

router> enable
password: ********
router# ?
<1-99>           Session number to resume
  bfe              For manual emergency modes setting
  clear            Reset functions
  clock            Manage the system clock
  configure        Enter configuration mode
  connect          Open a terminal connection
  copy             Copy a config file to or from a tftp server
  debug            Debugging functions (see also 'undebug')
  disable          Turn off privileged commands
  disconnect       Disconnect an existing network connection
  enable           Turn on privileged commands
  erase            Erase flash or configuration memory
  exit             Exit from the EXEC
  help             Description of the interactive help system
  lock             Lock the terminal
  login            Log in as a particular user
  logout           Exit from the EXEC
  name-connection  Name an existing network connection
  no               Disable debugging functions
  pad              Open a X.29 PAD connection
  ping             Send echo messages
  ppp              Start IETF Point-to-Point Protocol (PPP) 
  reload           Halt and perform a cold restart
  resume           Resume an active network connection
  rsh              Execute a remote command
  send             Send a message to other tty lines
  setup            Run the SETUP command facility
  show             Show running system information
  slip             Start Serial-line IP (SLIP)
  start-chat       Start a chat-script on a line
  systat           Display information about terminal lines
  telnet           Open a telnet connection
  terminal         Set terminal line parameters
  test             Test subsystems, memory, and interfaces
  traceroute       Trace route to destination
  tunnel           Open a tunnel connection
  undebug          Disable debugging functions (see also 'debug')
  verify           Verify checksum of a Flash file
  where            List active connections
  write            Write running configuration to memory, network, or terminal
  x3               Set X.3 parameters on PAD
   
$$$ Nos ha pedido otra password y ha cambiado el prompt de ">" a "#" para 
$$$ indicar el modo. Para volver al modo normal solo hay que introducir el 
$$$ comando "disable". Ahora aparecen mas opciones.

Hare una parada en la demostracion para hacer una serie de explicaciones (muy
por encima, eso si). En principio hay cuatro tipos de comandos:

1. Comando "Show": muestra la configuracion o los datos de un servicio
2. Comandos de configuracion (hay que entrar en modo "configure")
3. Comandos "Debug": Hace que el router envie una secuencia de testeo y 
   devuelve un informe
4. Comandos TCP/IP de testeo: telnet, ping, traceroute, etc. estos paso de 
   explicarlos porque ya estareis hartos de usarlos ;) 

$$$ A~adiendo "?" a un comando nos devuelve una ayuda, por ejemplo:

router# show ip ?
  accounting      The active IP accounting database
  aliases         IP alias table
  arp             IP ARP table
  cache           IP fast-switching route cache
  community-list  List community-list
  eigrp           IP-EIGRP show commands
  interface       IP interface status and configuration
  irdp            ICMP Router Discovery Protocol
  masks           Masks associated with a network
  nhrp            NHRP information
  protocols       IP routing protocol process parameters and statistics
  redirects       IP redirects
  route           IP routing table
  sockets         Open IP sockets
  tcp             TCP/IP header-compression statistics
  traffic         IP protocol statistics                                                        

$$$ Volvemos al router, utilizare las ordenes mas simples y las ire 
$$$ comentando:

router#show users
   Line     User      Host(s)               Idle Location
*  1 vty 0             idle                     0 Hendrix.esmentira.com
          
$$$ Vaya, estoy solo. (La explicacion de "Line" y "vty" para el proximo dia, 
$$$ vale?)

router#show version

Cisco Internetwork Operating System Software
IOS (tm) 1000 Software (C1005-Y-M), Version 10.3(7), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-1995 by cisco Systems, Inc.
Compiled Wed 01-Nov-95 15:34 by vatran
Image text-base: 0x05008000, data-base: 0x023F5324

ROM: System Bootstrap, Version 5.3.2(6) [vatran 6], RELEASE SOFTWARE (fc1)
ROM: 1000 Bootstrap Software (C1000-RBOOT-R), Version 10.3(6), RELEASE SOFTWARE
(fc1)

router uptime is 50 weeks, 7 days, 13 hours, 57 minutes
System restarted by power-on
System image file is "flash:c1005-y-mz.103-7", booted via flash

cisco 1000 (68360) processor (revision 0x00) with 3584K/512K bytes of memory.
Processor board serial number 32325888
Bridging software.
X.25 software, Version 2.0, NET2, BFE and GOSIP compliant.
1 Ethernet/IEEE 802.3 interface.
1 Serial network interface.
8K bytes of non-volatile configuration memory.
4096K bytes of processor board PCMCIA flash (Device not programmable)

$$$ Tachan!!! Este es el Router: un Cisco 1005 con Cisco IOS 10.3.
$$$ Tambien podeis ver otras cosas: Microprocesador 68360, (Motorola, como el
$$$ Amiga!) 4 Megas de RAM, una tarjeta PCMCIA con 4 Megas mas, una tarjeta 
$$$ Ethernet y otra tarjeta serie (para una conexion Frame Relay, se 
$$$ supone) 
$$$ Tambien incluye software para X.25 y software de Bridge, aunque no se
$$$ utilizan                

router#show interfaces 

Ethernet0 is up, line protocol is up
  Hardware is QUICC Ethernet, address is 0000.0f112.ffff (bia 0000.0f112.ffff)
  Internet address is 197.111.1.2 255.255.255.0
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec, rely 255/255, load 1/255
  Encapsulation ARPA, loopback not set, keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 4:00:00
  
Serial0 is up, line protocol is up
   
Serial0.1 is up, line protocol is up
  Hardware is QUICC Serial
  Internet address is 10.1.1.1 255.255.255.252
  MTU 1500 bytes, BW 1024 Kbit, DLY 20000 usec, rely 255/255, load 1/255
  Encapsulation FRAME-RELAY IETF
Serial0.2 is up, line protocol is up
  Hardware is QUICC Serial
  Internet address is 10.1.1.2 255.255.255.252
  MTU 1500 bytes, BW 1024 Kbit, DLY 20000 usec, rely 255/255, load 1/255
  Encapsulation FRAME-RELAY IETF  

$$$ Tambien aparecen estadisticas de paquetes cursados, paquetes erroreos,
$$$ etc, pero me lo salto porque ocupa mucho. Lo que si podeis ver es la 
$$$ configuracion de la tarjeta Ethernet (IP:197.111.1.2), 10Mb de BW.
$$$ Tambien tiene una tarjeta serie con 2 conexiones Frame Relay a 10.1.1.1 y
$$$ a 10.1.1.2 El ancho de banda es de 1 Mb cada conexion.

router#show arp
Protocol  Address       Age (min)     Hardware Addr  Type   Interface
Internet  197.111.1.1          87     0600.0c07.ffff ARPA   Ethernet0
Internet  197.111.1.11          7     0600.09d0.3fe0 ARPA   Ethernet0
Internet  197.111.1.10          4     0660.b0ee.e4ee ARPA   Ethernet0
Internet  197.111.1.19          3     0600.09ee.7e74 ARPA   Ethernet0
Internet  197.111.1.18          1     0600.0ee9.a6aa ARPA   Ethernet0
Internet  197.111.1.14         21     0600.0333.5aab ARPA   Ethernet0
Internet  197.111.1.20          9     0600.099a.2633 ARPA   Ethernet0
Internet  197.111.1.102        32     0620.aff6.5335 ARPA   Ethernet0

$$$ siempre va bien ver el resto de ordenadores conectados a la red local, 
$$$ Veamos ahora el fichero de configuracion:
$$$ Los comentarios del fichero son mios, no os vayais a liar.

router#show configuration

version 10.3                    /* Version del Cisco IOS */
service udp-small-servers       /* servicios activos */  
service tcp-small-servers
!
hostname router                 /* nombre del router */ 
!
enable secret 5 $7$5fr3$Lblju33t7NjnSUThFgxy34 /* clave secreta encriptada */
enable password holahola                       /* clave para acceso por el 
                                                  puerto serie */
!
!
interface Ethernet0			/* Configuracion de la T.de Red */
 ip address 197.111.1.2 255.255.255.0       
!
interface Serial0			/* configuracion de Frame Relay */
 no ip address
 encapsulation frame-relay IETF
 frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
 ip address 10.1.1.1 255.255.255.252
 frame-relay interface-dlci 510    
!
interface Serial0.2 point-to-point
 ip address 10.1.1.2 255.255.255.252
 frame-relay interface-dlci 512
!
ip host otro1 10.1.1.1
ip host otro2 10.1.1.2
snmp-server community public RO
!
line con 0
 exec-timeout 40 0
line vty 0 5                /* conf. acceso remoto */
 password hola
 login
!
end     

$$$ El DLCI es como la direccion IP pero para una red Frame Relay.
$$$ (Que estais pidiendo un cursillo de Frame Relay?, bueno, me lo apunto
$$$  para otra). 

router> exit

Se acabo por hoy, otro dia mas.
PD: no os molesteis en copiar las IP de este ejemplo ya que TODOS los datos 
son falsos, no vaya a ser que se moleste el due~o del router ;)